Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Conflict with Advanced Modules

Conflict with Advanced Modules

I installed MetaMod PRO on a site where I had already installed Advanced Modules. Apparently those two don't work together trouble-free. Only after I disabled Advanced Modules, MetaMod PRO worked as expected. I'm not insinuating Advanced Modules is to blame; it's just an observation which I reported in the Advanced Modules forum as well. Hopefully one or both of you can figure out what the conflict is and resolve it.

pjdevries
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

Hi pjdevries,

Yes, it's no surprise that there will be a conflict between the two systems. Both Advanced Modules and MetaMod Pro use a very similar technique at a low level in Joomla to allow complex manipulation of modules.

Joomla does not currently (in Joomla 1.5) provide official "hooks" into that part of the system in order for plugins to be able to manipulate the modules. If Joomla did, then Advanced Modules and MetaMod Pro could probably both co-exist. At present, both systems override some fundamental Joomla behaviour, and one or the other of them will "win".

I'm trying to convince the main Joomla developers to add such hooks into the module system for Joomla 1.6. (see this discussion on the joomla dev list. I don't imagine that we'll manage to get it into Joomla 1.5.

Hope that clears things up. I am not sure we'll get a good resolution on this, but I would like to have a chat to Peter about ways we might be able to co-exist better.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

Thanks for the reply.

Your explanation makes sense. Peter seems a nice guy, so I'm sure he'll appreciate it, if you get in touch and try to find a resolution.

Good luck.

pjdevries
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

I have exactly the same problem, the conflict has been resolved? if not what files and assumptions to find a solution?

agoui
Beginner Modder
ranks
useravatar
Offline
1 Posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

Hi,

Peter and I have been contributing to a discussion on how to get Joomla 1.6 changed to allow both sets of plugins to work. My hope is that once we settle on a good architecture for 1.6, we'll be able to use that same architecture now in 1.5 to solve the problem. Unfortunately with Christmas coming up the discussions have slowed down again, so thanks for the reminder! We're both committed to finding a solution. There are a few technical challenges, but as I said we also want the changes that we propose to core files to be able to be used directly in the next version of Joomla. This will help to future-proof both of our plugins.

Sorry it's taking a while.

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

Hi Folks,

good news - Peter and I have collaborated on new versions of MetaMod Pro (v2.2) and Advanced Module Manager (v1.8.0). Existing MMP customers can pick up their free upgrade following instructions on http://www.metamodpro.com/forums/topic?id=271

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Conflict with Advanced Modules

Hi all,

I have upgraded my Metamod Pro v2.2 and Advanced Module Manager v1.8.0 and guess what? It works right out the box!

Superb and seamless integration indeed!

pembaris
Beginner Modder
ranks
useravatar
Offline
16 Posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1667
Total Polls:
6
Total Posts:
5909
Posts this week:
1
User Info:
 
Total Users:
10113
Newest User:
michael2066
Members Online:
1
Guests Online:
206

Online: 
michael2066

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked