Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Error in rule tab

Error in rule tab

500 - An error has occurred.

Table 'mydatabasename.sdpr_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `sdpr_chameleon_rule` as a LEFT JOIN sdpr_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering Table 'mydatabasename.sdpr_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `sdpr_chameleon_rule` as a LEFT JOIN sdpr_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering LIMIT 0, 20 Table 'mydatabasename.sdpr_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `sdpr_chameleon_rule` as a LEFT JOIN sdpr_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering Table 'mydatabasename.sdpr_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `sdpr_chameleon_rule` as a LEFT JOIN sdpr_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering


i get this error can you help me please?

Edited By: ddweb
05-Oct-11 15:35:07

ddweb
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error in rule tab

Hi ddweb,

it looks like the installer didn't install it all properly. Can you try to do the install again, over the top of the old one? Do you get any errors when doing the install?

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Error in rule tab

hi, i have install it again but i get this error again... in the installation i dont get any error... what i can do?

ddweb
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error in rule tab

Oh dear, looks like some sort of database error that's not being reported...

Do you have access to phpMyAdmin to get raw access to your database? Can you please go in and have a look to see if there is a table called sdpr_chameleon_rule ?

If not, you could use this command in the SQL box in phpMyAdmin to try to create the table?

CREATE TABLE IF NOT EXISTS `sdpr_chameleon_rule` (
  `id` int(11) NOT NULL auto_increment,
  `published` tinyint(1) NOT NULL default '0',
  `title` varchar(255) NOT NULL,
  `comments` text NOT NULL,
  `rule` text NOT NULL,
  `params` text NOT NULL default '',
  `ordering` int(11) NOT NULL default '0',
  `checked_out` int(10) unsigned NOT NULL DEFAULT '0',
  `checked_out_time` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',

  PRIMARY KEY  (`id`)
) ENGINE=MyISAM AUTO_INCREMENT=0 DEFAULT CHARSET=utf8;


Hope that works - please report any errors you get with this.

[I should add that you're the first to ever report this problem, and I suspect there are some underlying issues in your Joomla/database setup causing the problem. Nevertheless I want to help you get this working]

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Error in rule tab

Hi,

we had this same issue. Tried your metod didn't help. Tried reinstalling didn't help. Only setting the server settings from Fast-CGI to suPHP worked. We prefer using Fast-CGI.

Greetings,
Anne

icinfo
Beginner Modder
ranks
useravatar
Offline
6 Posts
Administrator has disabled public posting

Re: Error in rule tab

Hi Anne,

I've seen this happen when someone tried to install the Joomla 1.5 version of Chameleon (e.g. the Lite version) onto J2.5+, then tried to install the proper version on top of that. It fails in a similar way to this.

If that's what happened, then you have to uninstall Chameleon before installing the correct version. You can't just install the correct version on top of the incorrect one UNLESS you uninstall first.

Can you please try that and let me know if it helps?

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Error in rule tab

Hi Stephen,

we didn't have the old J1.5 version but only the new version 2.36, so that is not the issue. We uninstalled and installed a few times always the same problem. Only after changing the server setting from Fast-CGI to suPHP the error message is gone and the component is accessible from the control panel. We normally use the Fast-CGI, but in that mode we get the error. In suPHP the component works normally.

- Anne

icinfo
Beginner Modder
ranks
useravatar
Offline
6 Posts
Administrator has disabled public posting

Re: Error in rule tab

Can you paste the exact error you get into a forum post please?

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Error in rule tab

Sure,  here it is:

500 - An error has occurred.
Table 'c89aps1.eke_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `eke_chameleon_rule` as a LEFT JOIN eke_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering Table 'c89aps1.eke_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `eke_chameleon_rule` as a LEFT JOIN eke_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering LIMIT 0, 20 Table 'c89aps1.eke_chameleon_rule' doesn't exist SQL=SELECT *,a.id, a.title, a.checked_out, a.comments, a.checked_out_time,a.published, a.ordering, a.params,uc.name AS editor FROM `eke_chameleon_rule` as a LEFT JOIN eke_users AS uc ON uc.id=a.checked_out WHERE (a.published IN (0, 1)) ORDER BY ordering


- Anne

icinfo
Beginner Modder
ranks
useravatar
Offline
6 Posts
Administrator has disabled public posting

Re: Error in rule tab

Ok, that's definitely a case of incorrect installation. The database table is supposed to be created as the extension is installed.

If uninstalling the component before re-installing it does not fix the problem, then if you can run SQL commands (perhaps via phpmyadmin on your cPanel) you could run this to create the table:

CREATE TABLE IF NOT EXISTS `eke_chameleon_rule` (
  `id` int(11) NOT NULL auto_increment,
  `published` tinyint(1) NOT NULL default '0',
  `title` varchar(255) NOT NULL,
  `comments` text NOT NULL,

  `rule` text NOT NULL,
  `params` text NOT NULL default '',
  `ordering` int(11) NOT NULL default '0',
  `checked_out` int(10) unsigned NOT NULL DEFAULT '0',
  `checked_out_time` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',

  PRIMARY KEY  (`id`)
) ENGINE=MyISAM AUTO_INCREMENT=0 DEFAULT CHARSET=utf8;


Hope that does it...
Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1679
Total Polls:
6
Total Posts:
5913
Dormant:
User Info:
 
Total Users:
10778
Newest User:
negina4qx
Members Online:
0
Guests Online:
126

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked