Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Lots of Errors on Fresh Install

Lots of Errors on Fresh Install

http://www.unccampus.com/system-chameleon-on.png
http://www.unccampus.com/system-chameleon-off.png


Warning: Invalid argument supplied for foreach() in /home/spanishb/public_html/components/com_chameleon/helper.php on line 195

Warning: Cannot modify header information - headers already sent by (output started at /home/spanishb/public_html/components/com_chameleon/helper.php:195) in /home/spanishb/public_html/administrator/components/com_frontenduseraccess/plugin_system/plugin_system2.php on line 618

Warning: Cannot modify header information - headers already sent by (output started at /home/spanishb/public_html/components/com_chameleon/helper.php:195) in /home/spanishb/public_html/administrator/components/com_frontenduseraccess/plugin_system/plugin_system2.php on line 619

Warning: Cannot modify header information - headers already sent by (output started at /home/spanishb/public_html/components/com_chameleon/helper.php:195) in /home/spanishb/public_html/components/com_community/libraries/core.php on line 609

Warning: Invalid argument supplied for foreach() in /home/spanishb/public_html/components/com_chameleon/helper.php on line 195

Warning: Cannot modify header information - headers already sent by (output started at /home/spanishb/public_html/components/com_chameleon/helper.php:195) in /home/spanishb/public_html/components/com_community/libraries/core.php on line 583

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

Oh dear - that's not good! Very sorry about this.

The problem seems to be triggered when Chameleon tries to loop through the list of published "rules", but there are none in the list (or the list is invalid in some way).

Could you try to create a new blank rule (just name it and publish it), and see if that gets rid of the problem?

I haven't been able to replicate the problem here - it works for me when there are no published rules. I'll have a look to see if there's any other reason why the list might be invalid.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

Hey,

Thanks for the Quick Reply.

I would if I could but it never created any admin links.

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

I managed to trigger this error by renaming the database table with the chameleon rules in it, so that chameleon couldn't find it. Can you please check to see if you have a database table named [your db prefix]_chameleon_rule   ? If you don't, then could you please try re-installing Chameleon over the top of itself and see if that table gets created?

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

I sent you admin details.

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

sure I will look...

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

I think I see the problem...

it is called "[your db prefix]_chameleonrule" instead of "[your db prefix]_chameleon_rule"

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

Right, it sounds like the install went a bit haywire.
By the way, the credentials you sent didn't allow me to log in to the back end. Can you check the groups?

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

okay, it should work now.

I must have switched group type over the past couple of days.

Odublar
Junior Modder
ranks
useravatar
Offline
22 Posts
Administrator has disabled public posting

Re: Lots of Errors on Fresh Install

That's verrrry strange - the entire code of the component does not contain the string "chameleonrule" without the underscore! (only in a couple of function names - nowhere in relation to the database).

There's something seriously screwy on your server!

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1681
Total Polls:
6
Total Posts:
5912
Posts this week:
6
User Info:
 
Total Users:
11501
Newest User:
riley58745
Members Online:
0
Guests Online:
175

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked