Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Module not displaying

Module not displaying

I have a module (related items) which i need to display only on the virtuemart product pages and not on category or any other pages on the site.

I have installed metamod-2-7
Metamod is enabled, all menu positions hidden, position right, quick position is set to "meta-mod", PHP is
if (
$option == 'com_virtuemart'
and JRequest::getVar('page') == 'shop.product_details'
and JRequest::getVar('flypage') == 'flypage.tpl'
) return 42; /* replace XXX with the module ID or position to display */


The module i want to display (Related Products, ID 42) is enabled
position meta-mod
menu positions none

But the module still doesn't display on the product pages:
http://love2wearlingerie.co.uk/index.ph … ;Itemid=17

I have :
Joomla Version 1.5.23
Metamod version 2-7
Virtuemart version 1.1.8 stable

This sounds a great product and i can see us using the pro version - if i can only get it to work! :-)

comdev
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Module not displaying

Hi Comdev,

1 - don't put anything in the "quick module id/position include" box if you're using a PHP rule. Just leave it blank.

2 - the rule you're using looks fine. You can either end it in return 42; or return "meta-mod";
You would return the module position if perhaps you had several modules that you wanted to use in that position, and it's easier to move things in and out of the meta-mod position than it is to edit the PHP each time.

3 - You mentioned that the MetaMod has "all menu positions hidden". Do you mean that the menu positions are set to "none"?

If so then that's the problem. The MetaMod itself has to be active and set to some or all module positions, otherwise it never gets run! Try setting that to "all" and I think it'll start to work.

Since the module you are adding is to go into the "right" column, you're likely to find that you're left with a blank space on the pages where the MetaMod does not include a module. This problem can be solved with MetaMod Pro.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Module not displaying

Hurray! it's working!

Thank you so much - i just need to buy the pro version to tidy up the other pages

comdev
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Module not displaying

Great, glad you're on the right track now - thanks for reporting back.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1667
Total Polls:
6
Total Posts:
5909
Posts this week:
1
User Info:
 
Total Users:
10119
Newest User:
watytb5
Members Online:
3
Guests Online:
229


Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked