Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Mod not showing

Mod not showing

Set the php to this to show on test site http://pregnant2day.org.uk/index.php
if ( $fromCountryId == "GB" ) return "71,70";

the modules specified does not show, must both GeoLiteCity and GeoIP be installed to let this php work.

acta123
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Mod not showing

Hi acta,

If you're just checking fromCountryId, then you only need the standard country database installed. Have you already downloaded that and put it into a folder called "/geoip" in your web hosting space?

Also make sure your MetaMod is published and assigned to ALL or to a subset of menus.

Try turning on MetaMod debugging mode to see what gets reported there.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Re: Mod not showing

I get his
MetaMod debug info:
Module ID: 73
$option: com_content
$view: frontpage
$id:
$Itemid: 1
$timezone: default
$language: en-za
$language_code: en
$language_region: za
Country: ZA
Country Name: South Africa
Country Code 2: ZAF
Region: 06
City: Johannesburg
Postal Code:
Latitude: -26.2
Longitude: 28.0833
DMA Code:
Area Code:
Rejecting: ZA is not in include lis

Here is my config screen shot. I want to show 69, but it does not work. I have asked friends in UK and they dont see it.
http://pregnant2day.org.uk/Baby2day.png

acta123
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Mod not showing

Hi acta123,

Thanks for the screenshot. I see that the MetaMod is in position "adv-top". However when I examine your site with this URL:

http://pregnant2day.org.uk/?tp=1

... I don't see a module position called adv-top. Could that be the problem? Perhaps try it in one of the other module positions like left-top and see if that makes a difference.

Also, are you using page caching? (e.g. the System-Cache plugin in the plugin manager) If so then this isn't going to work well with GeoIP location of modules, so best to turn the page caching off.

Lastly, for testing of course you can try your own country code, ZA.

Hope that helps - please write back if you still can't get it working. I'm sure it's something simple.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1686
Total Polls:
6
Total Posts:
5933
Total Posts Today:
7
User Info:
 
Total Users:
4432
Newest User:
kinggambling14
Members Online:
0
Guests Online:
187

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked