Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Getting warning message : Warning: Invalid argument supplied...

Getting warning message : Warning: Invalid argument supplied...

Hi Stephen, I am getting a warning message when I am using a "?landing=x" from a RsForm!Pro page or TO an RsForm!Pro page.

Warning message wrote:

Warning: Invalid argument supplied for foreach() in /home/guitar88/public_html/plugins/metatemplate/extendedrules.php on line 467

You can reproduce the warning message using this link (add www.quebecguitare.com/ before it):

Code:

/index.php?option=com_rsform&view=rsform&Itemid=650?landing=3

Joomla reporting is set to default.
I updated sh404sef and RSForm!Proto the latest version couple days ago already without any problem.

It's just a warning, it only slow down the page flow and looks silly hehe...

Cheers,
Alex

atherrien
Modder Extraordinaire
ranks
useravatar
Offline
140 Posts
Administrator has disabled public posting

Re: Getting warning message : Warning: Invalid argument supplied...

I got another one, same context, except I get it in a metamod going to a specific template triggered with "?landing=2". Once again, outgoing from an RSFORM!PRO:

Warning on metamod wrote:


Warning: Cannot modify header information - headers already sent by (output started at /home/guitar88/public_html/plugins/metatemplate/extendedrules.php:467) in /home/guitar88/public_html/modules/mod_metamod/helper.php(537) : eval()'d code on line 31

So this string triggers it only when the cache is empty. This is for a video module that loads just once if you remember:

String URL wrote:

/index.php?option=com_rsform&view=rsform&Itemid=650?landing=2

atherrien
Modder Extraordinaire
ranks
useravatar
Offline
140 Posts
Administrator has disabled public posting

Re: Getting warning message : Warning: Invalid argument supplied...

Ok, I found the problem. It's not actually RS!Form that's causing the problem -- the problem occurs when both (i) you are trying to detect pages by menu item, and (ii) the user goes to a page with an invalid Itemid.

I have put some additional checking into MetaTemplate Pro so that this situation does not cause a warning to be displayed.

You can pick up the new copy of MetaTemplatePro 1-11c from the instructions in the yellow box on http://www.metamodpro.com/metatemplate/download

Thanks so much for reporting this!

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3319 Posts
User info in posts
Administrator has disabled public posting

Re: Getting warning message : Warning: Invalid argument supplied...

Great stuff! It fixes it as usual!! I am so happy with your support!! Thank you so much Stephen!

Cheers,
Alex

atherrien
Modder Extraordinaire
ranks
useravatar
Offline
140 Posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1675
Total Polls:
6
Total Posts:
5917
Posts this week:
6
User Info:
 
Total Users:
11577
Newest User:
owens65784
Members Online:
0
Guests Online:
189

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked