Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

I'm using Joomlart's T3 (v2) framework. I've installed metamod and metamod pro 2.5 plugin.

However when I enable the metamod pro plugin and refresh my fontend, the frontend is just blank. If I disable the plugin and refresh, all is good.

I've ordered my plugins and placed metamod pro first but still have the same problem.

Can anybody offer any advice or even tell me if metamod is NOT compatible with T3 framework.

Thanks

otooles
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

Hi otooles,

I haven't tested MetaMod Pro directly with the JA T3 framework. However recently I have seen some other situations where MetaMod Pro caused a "white screen of death". These were all to do with clashes with other plugins in the system, or the ordering of plugins.

Here's what I have found:

1 - it's often necessary to place any 3rd-party SEF plugins before MetaMod Pro. So if you are using sh404SEF or AceSEF (or probably others too), then try placing them first on the list followed by MetaMod Pro.

2 - there are some plugins that use non-standard methods of importing the module helper class. These can cause the white screen of death. I recently came across a plugin called "module" that broke MMP because it imported the class wrongly. BreezingForms is another that causes problems, or at least has done in the past. You can read more about those here:

http://www.metamodpro.com/forums/topic?id=11#p16


I think it would be useful to test the theory about whether it's the T3 framework that is the problem, or whether the problem occurs even with a normal template. Could you try switching to the Beez template for your site (one of the built in ones), and try loading the same page? If it still fails then it's likely *not* the T3 framework.

Please let me know how you get on. Since the T3 framework does some interesting things with modules, it's possible that there's some incompatible code in there. Normally this is not hard to fix though.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

PS I just download the ja_purity_ii template which uses T3, and it worked with no problems on my test server, with MetaMod Pro. So I think it's one of your other plugins that's causing the problem. If you're able to search the source code in the plugins folder, you could search/grep for the phrase "module/helper.php" which is often in a line like this:

require_once(dirname(__FILE__).'/../../libraries/joomla/application/module/helper.php');

It's sometimes written more like this: ...   DS . 'module' . DS . 'helper.php');

This is the wrong way to include the module helper class, and interferes with MetaMod Pro which provides a different implementation of that class. The right way to include the module helper class is this (which can replace the line above):

jimport('joomla.application.module.helper');

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

Thanks Stephen, I disabled all my plugins and left just the t3 and metamodpro plugins enabled. But no joy. Still blank white screen.

Thanks for your help, I'll dig a little further...

otooles
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

Hi otooles,

when you say you disabled all the plugins, was that *all* plugins (including Content ones) or just the System ones? Try including the Content ones too, if you weren't already.

If you're stuck I'm happy to log into your site and do some more debugging - just PM me an administrator login and password and I'll take a look.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: MetaMod Pro 2.5 Not compatible with T3 v2 Framework?

Good news - the new version of MetaMod Pro v2.6, now fixes a compatibility problem with Joomlart T3v2 templates.

If you're using a T3v2 template, then please upgrade the T3v2 system plugin (from Joomlart).

Also, if you're using NoNumber's Advanced Module Manager, then please upgrade that to the latest version (at least v1.13.1).

Existing customers: to download the latest version of MetaMod Pro:

  • Go to your “My Account” page
  • Log in with your username and password
  • Click on “View” next to your confirmed order
  • Scroll down past the invoice until you see the Order Items section
  • Click on plug_metamod-X-X-X.zip to download it.

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1684
Total Polls:
6
Total Posts:
5940
Posts this week:
1
User Info:
 
Total Users:
5161
Newest User:
kbmgkey234q
Members Online:
0
Guests Online:
187

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked