Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Hi. smile I am trying to make a login/logout menu as per JoomlaFare's tutorial. I am pretty sure I followed all the steps, I went back over it a couple of times. I receive this error when the mod in enabled: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error and it tells me that the site is unavailable or moved. I do not receive the error when I disable the mod. I am on a local machine running Apache/php5. Not sure what is going on and any help would be appreciated.

p.s. I have also tried disabling SEF links in the global config section of Joomla.

Thanks much!
Kate

redfraggle42
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Can you paste the exact PHP code that you used? It's likely just a typo in there. Some sites get really touchy about that - others just show a more friendly error. Yours is no doubt one of the former!

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

if ( MM_LOGGED_IN ) return 150
else return 17;

the site is showing up now, not sure what i did. lol. but the menu will not show up. I set the 2 menus to the drawer position (very top) published.

as well as the mod

forgot the ; after 150 although still not showing up.

redfraggle42
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Hi Kate,

Yes, the ";" after the 150 is exactly the sort of typo I was meaning!

You say that you set the 2 menus to the drawer position, as well as the MetaMod, and they are all published. Can you please read through the Quick Start Guide (http://www.metamodpro.com/metamod/quick-start) and make sure you follow the instructions on that page? Especially to do with the target modules being published/unpublished or set to "none" pages etc.

Any luck now?

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

ok. making headway. I read and reread the Quick start as well as the JoomlaFare tutorial. I set the module position for the login and logout menus to drawer-metamod, published them, and set menus to none. When I use the Quick Module Position box set to drawer-metamod both menus show up (not what I am looking for), but if I remove that and put this in the php box:

if ( $user->name == "" ) return 153;   
else return 150;

I get that error again.

Other metamod settings:
menu class suffix: user
auto enable: none
style for included module: horizontal
Show Quick Module: all users

Joomla: v 1.5.20

I really appreciate your help. smile

Kate

Note: whem I am logged in it shows both menus. When I am logged out it only shows the login menu.

redfraggle42
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

ok I just tried a hunch. I installed on the live server and it works fine. It must be something with the way my localhost PHP is configured or something. Who knows. *sigh* The important thing is that it works. Thanks for your time, sorry to waste it. smile

Kate

redfraggle42
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Hi Kate, glad you got it working - phew!

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

i'm also having this problem

kinjo
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

i found my fix
http://www.deskdecode.com/err_connection_timed_out/
its only my chrome who's creating the problem

kinjo
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

Hi, so did you manage to fix the problem by trying any of the solutions on that page?

Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1666
Total Polls:
6
Total Posts:
5909
Dormant:
User Info:
 
Total Users:
10091
Newest User:
lamanaudio
Members Online:
3
Guests Online:
136


Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked