Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Metatemplate Pro will not work properly

Metatemplate Pro will not work properly

I have a menu with all different regions on it, I would like when someone selects one of the regions it takes them off the a different template. I have not been able to achieve this so far. Could you explain how I might be able to do this with the pro version of meta template

Wallies
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Metatemplate Pro will not work properly

Hi Wallies,

I am assuming that you mean that you have a main menu with 3 items on it, maybe something like this:

London - Glasgow - Edinburgh

Perhaps you also have some "child" menus, e.g. "shopping" and "transport", under each top level menu item, e.g.

London
- shopping
- travel
Glasgow
- shopping
- travel
Edinburgh
- shopping
- travel

In MetaTemplate Pro, you have a selector box that shows you all the different menu items available.

So I would create 3 different MetaTemplate rules:
- in 1, select "London" from the menu selector, and select "Include selected items and their children" from the drop-down above it. Then in the "SUCCEED ACTION" on the right, select the appropriate template for all the London pages.
- in 2, do the same for "Glasgow"
- in 3, do the same for "Edinburgh".

That's the way it's supposed to work. If rule 1 fails (i.e. the menu item is not "London" or one of its child menus) then MetaTemplate will jump down to the next rule and try that one, and so on. If one of the rules does match, then it will set the appropriate template.

If this still doesn't work, please write back. Perhaps I didn't understand your setup properly.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3319 Posts
User info in posts
Administrator has disabled public posting

Re: Metatemplate Pro will not work properly

This is exactly what I want to do, the thing is I followed exactly what you said and it is still not working, is there something I am missing, I have a feeling it is something simple.

Wallies
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Metatemplate Pro will not work properly

Hi Wallies,

just worked out what was wrong: you're using ARTIO JoomSEF. That in itself is fine, but the system plugin for ARTIO JoomSEF was below the MetaTemplate plugin. So I set ARTIO JoomSEF to "-100" and MetaTemplate to "-90" in the ordering, and now it works :-)

I put all the rules back the way they were before, but I tested to see if I could set a menu item & its children to trigger a template. Before I changed the plugin ordering, this didn't work. Now that I changed it, it does work.

So now you can go ahead and set up some MTP rules and I think you'll find it all working properly.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3319 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1675
Total Polls:
6
Total Posts:
5917
Posts this week:
6
User Info:
 
Total Users:
11570
Newest User:
moises1247
Members Online:
1
Guests Online:
166

Online: 
moises1247

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked