Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Getting Error loading module when using conditional recipe

Getting Error loading module when using conditional recipe

Which version of Joomla? 1.5.17
Which version of MetaMod are you using? 2.4c Pro
Using a Yootheme: Enterprise
If you are having trouble with a particular recipe, please include the complete recipe:

tried:

if ( $option == 'com_k2'
) return 8;
else return 1;

and also:

if ( MM_LOGGED_IN ) return 8;
else return 1;

currently, the fist recipe is loaded, see:

http://nvcacademy.net/2/index.php for menu ID 1
http://nvcacademy.net/2/index.php?optio … Itemid=192   for menu ID 8

Error msg:  Error loading Modules:

I have tried:

1. moving default menu link to the other menu in the recipe
2. creating new menus
3. swapping 1 and 8, the issue stays with the conditional part of the recipe.
4. non-conditional recipes seem to work.

thanks.

Mark

Edited By: nvcacademy
05-Aug-10 16:56:45

nvcacademy
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Getting Error loading module when using conditional recipe

Hi Mark,

Check that modules 1 and 8 definitely exist. #1 is normally a "main menu" module if you installed the demo data to start with. Module #8 I don't think exists on a standard install, and the module ID numbers auto-increment from about 41 onwards. Therefore, I wonder if you might be confusing menu ids with module ids.

The error you are getting occurs when MetaMod does a lookup in the database for the module ID(s) you have returned, but doesn't find anything with that ID.

If you're positive that module #8 exists then I'll look again... but no-one else has ever reported an error in that part of MetaMod.

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Re: Getting Error loading module when using conditional recipe

I was using the menu ID number, which is the same module and menu ID numbers (1) for the default Joomla menu, but not the menu I created, it's 251 not 8. It's working now. thanks.

nvcacademy
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Getting Error loading module when using conditional recipe

You're welcome

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1686
Total Polls:
6
Total Posts:
5933
Total Posts Today:
7
User Info:
 
Total Users:
4432
Newest User:
kinggambling14
Members Online:
0
Guests Online:
185

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked