Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

I hate to ask this question because I think it is probably a new user problem. I searched and searched, but didn't find it, so here goes:

Hi Stephen,

I have successfully used MetaMod (Pro) for a little while now, using the random recipe:

$r = rand(1,7); // get a random number: 1-7 inclusive
if ($r == 1) return 130;
if ($r == 2) return 138;
if ($r == 3) return 139;
if ($r == 4) return 140;
if ($r == 5) return 141;
if ($r == 6) return 148;
if ($r == 7) return 149;

on a position that is designed to show on all pages. Worked great.

Using the same format recipe, I yesterday created a metmod (pro) module to appear on the front page only, just two modules, it works just fine, choosing the radio button marked “None”.

Here's the problem: Recently I installed Peter's Advanced Module Manager. The above works when AMM is disabled, but as soon as I enable it, the metamod (pro) module appears on every page. I had already installed AMM before I created this new metamod (pro) module, and found out the hard way.

I disabled it, made sure that "none" was chosen, checked, worked okay, enabled AMM, shows on every page again.

Do I just not know how to choose "none" on AMM? I am not using the pro features, both modules are the same exact size, one has a little module class suffix.

I can hardly believe that something so simple as appearing on just one page is really any sort of bug since you and Peter have made it totally compatible.

If you can point me in the right direction, I will fix this and then go hide my head in shame.

asr

edit: I do have the most up to date version of metamod, the pro plugin, AMM.

Edited By: asroot
28-Jun-10 19:35:57

asroot
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Hi Asr,

I just installed the latest version of AMM, and indeed this is broken - the 2 components are not playing nicely together :-(

Don't worry about the "none" thing on AMM. If you just set the module to Disabled, then MetaMod is happy with that. But the core problem here is something deeper which I will need to talk to Peter about.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

UPDATE: I just checked through my versions again, and ensured I had AMM v1.9.2 and MetaMod Pro v2.4 installed. They weren't. So I re-installed and everything seems to be working again.

During the process I actually de-installed AMM, installed an older version, then upgraded that to 1.9.2 again, so it's possible that it was that process that fixed things - I can't
be sure.

Can you check again to make sure you have these versions? And if it won't disrupt your site too much, perhaps you could uninstall both of them, then re-install them, just to be on the safe side?

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Hi Stephen,

Well, I did not have the latest AMM, I had 1.91, apparently posted today? I will install.

I don't see metamod pro 2.4 announced on the download page, it says 2.3 from April is the latest. I go to My Account, view the purchase, etc, it says: "plug_metamod-2-3.zip"

Confused again.

asr

asroot
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Ah, looks like I never released MetaMod Pro 2.4. Sorry about that! I'll try and get that released this week as well, and will e-mail you a copy.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Thanks Stephen. Much appreciated. smile

asroot
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Hi Stephen,

I have installed the new metamod pro plugin 2.4 that you e-mailed me, and I have AMM 1.92 installed. I tried the experiment again, and unfortunately it still is appearing on all pages.

I did not try the uninstall both, reinstall both idea yet, because I wanted to first ask:

Is there a new 2.4 MetaMod (the module part) also? My Metamod (mod) is still 2.3 as that is still what is download-able.

I wanted to check on this before going further.

Thanks,

asr

asroot
Beginner Modder
ranks
useravatar
Offline
5 Posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Hi asr,

sorry for the delay in getting back to you, I have been deluged by other work for a few days.

The latest MetaMod is 2.3, and MetaMod Pro is 2.4. The two versions don't match - it's just coincidence that they were the same for some time! So go ahead with v2.3.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

... and by the way, MetaMod Pro v2.4 is now available for download for registered users. Just log in to your account, click on your order, and scroll down to the download section.

Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: A Metamod (Pro) - Advanced Module Manager Problem - It Must Be Me

Stephen,
I just stopped this post. I didn't want to create a new one.
I am running 1.5.20
MetaMod 2.4c
MetaMod Pro 2.4
and Advanced Module Manager 1.9.7

This site has been working for a good three months. I upgraded about 1 month ago to 2.3 and my module broke and would be displayed on all pages.

What I am trying to do in only have module 175 display everywhere except the Store with I have excluded on the menu. I am doing this the same as before.

Also, I uninstalled everything all plugins, metamod, and advanced module mgr. Then cleared cache and reinstalled.

I am still having the same issue.

Any help would be appreciated.
Michael

michaelyork06
Beginner Modder
ranks
useravatar
Offline
3 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1686
Total Polls:
6
Total Posts:
5940
Total Posts Today:
1
User Info:
 
Total Users:
5198
Newest User:
Paramountdental
Members Online:
0
Guests Online:
138

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked