Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

JoomFish Advanced SEF problem

JoomFish Advanced SEF problem

Hi,

recently, I've downloaded the JoomFish Advanced SEF component from this site.
The problem I was having with Joomfish was solved, but now another problem occurs:

My site has 2 languages and when I'm on the homepage and want to switch languages, I'm getting a 404 page.

Basically, the problem is that the homepage url's www.mysite.com/nl & www.mysite.com/en don't seem to work.

Or am I missing something in the configuration?

motofzr1000
Beginner Modder
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Hi motofzr1000,

can you tell me what version of JoomFish you have?
Also what version of Joomla?
Also, are you using Joomla's built-in SEF system, or another one like JoomSEF or SH404SEF? As far as I know, this plugin only works with Joomla's built-in SEF system.

I'll need to test it out to see if I can replicate it - I haven't seen this error before.

Thank for any info,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Hi,

thanks for your reply.
I'm using Joomla 1.5.15, Joomfish 2.0.4 and Joomla's built-in SEF system.

motofzr1000
Beginner Modder
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

ok, I've been able to replicate that. I can't believe I hadn't seen the problem before... I'll play with this some more on my machine and let you know what I come up with.

Sorry for the inconvenience!

I have this running on a live site, and it works fine there, so I don't know what's going on at all.

Stephen

p.s. at the end of the day, this plugin was provided with no guarantee except "it works for me", so if I can't fix it in a hurry then I'll just have to leave it for now due to lack of time, sorry.

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Hi motofzr1000,

thanks again for reporting this bug.

I've tracked down the bug and have fixed it. Version 1.1 of the plugin is now available from http://www.metamodpro.com/software/jfsef

All the best,
Stephen Brandon

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Hi,

thanks a lot for the fix.
Everything's OK now.

motofzr1000
Beginner Modder
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Great, thanks for reporting back.

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3312 Posts
User info in posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

Hi,
I installed JoomFish Advanced SEF sucessfully + joomla 1.5.20 and it works beacause i have not more 404 error when i click on a flag language but the name of the url be left in the default language, e.g.:
www.mysite.xxx/es/english-title.html
it must to be:
www.mystie.xxx/es/spanish-title.html
thanks in advance

elasticgirl
Beginner Modder
ranks
useravatar
Offline
2 Posts
User info in posts
Administrator has disabled public posting

Re: JoomFish Advanced SEF problem

I have to disable the ARTIO JoomSEF component and the plugin System - ARTIO JoomSEF and finally it works fine!
very thanks

elasticgirl
Beginner Modder
ranks
useravatar
Offline
2 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1666
Total Polls:
6
Total Posts:
5909
Dormant:
User Info:
 
Total Users:
10095
Newest User:
johnson58
Members Online:
0
Guests Online:
89

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked