Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Device detection

Re: Device detection

sorry I have a problem !

I tested only the ipad detection which is working great, but apparently you changed something in the advanced settings because my old rules allowing people to change template by clicking a link with the code

"if (JRequest::getInt("mobile",0) == 1) return true; else return false;"

do not work any longer !

alterna
Beginner Modder
ranks
useravatar
Offline
18 Posts
Administrator has disabled public posting

Re: Device detection

Are you saying that the link on your site has "&mobile=1" in it, and your rule is designed to pick this up and use it to switch template?

If so, it's hard to imagine that any of the recent MTP changes would have affected this...

Try checking a few things:
1- what actions are being taken as a result of the "mobile=1" rule above? e.g. does this set a template? Then is that rule set to "continue to next rule", or to stop processing rules?
2- do you have any rules before the "mobile=1" rule that might be setting an alternative template before it even gets to that rule? Or even that "stop processing" so it never continues to check for "mobile=1"?

I'd suggest going through the rules one by one to follow the logic and make sure that your rule gets reached, and that there aren't any other rules running after it that are overriding the template that you set there.

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: Device detection

Stephen,

There should be a change somewhere because I did not change my rules and it was working very well until the previous version.

Didn't you change something in the advanced detection ?

It looks like the php condition does not return the proper success/fail as it was before

alterna
Beginner Modder
ranks
useravatar
Offline
18 Posts
Administrator has disabled public posting

Re: Device detection

Hi alterna,

Well there were some changes to various parts of MetaMod Pro, but I am a bit surprised that this would have stopped your recipe from working. Can you answer the questions in my last post so that I can understand the setup a bit more?

If you're willing for it, I'd be happy to log into your site and check the setup and see what's going on. Just PM me an admin login if you want me to do that.

Very sorry for the inconvenience. I want to get this sorted out for you.

Best regards,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1688
Total Polls:
6
Total Posts:
5939
Dormant:
User Info:
 
Total Users:
6886
Newest User:
shafn31a2
Members Online:
1
Guests Online:
115

Online: 
shafn31a2

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked