Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

template switching not working at all. please help.

template switching not working at all. please help.

Ok. So i created a rule that will change templates when accessing an article from a different section, it doesn't work. The rule i set was, on "Content and Compoents" I set the section i wanted to use the template i wanted. I assume that will set the correct template when I access any article with in that section, right? then on succeed, I hit process next rule chain, and FAIL actions i hit process next rule in chain. But when I try to access my main site, it sets the template rule i created as the main template for the whole site. What am I doing wrong?

maitai
Beginner Modder
ranks
useravatar
Offline
1 Posts
Administrator has disabled public posting

Re: template switching not working at all. please help.

Hi maitai,

This is with MetaTemplate Pro, right?

If you're just using a single rule, then it doesn't matter what you select for "process next rule" or "stop processing" -- these are only relevant if you have further rules that may or may not need to be processed based on the results of the 1st rule.

The crucial step is to use the dropdown to select the new template in the SUCCEED action, near the bottom of the page. Don't use the list of templates in the right column (with the radio button next to them) as that sets the default template, not the template to be used as a result of the current rule. Does that make sense?

To help with testing, you might want to set a completely different template for the SUCCEED action and the FAIL action, just so you can see if the result of the rule you created was a SUCCEED or FAIL. I quite often use the built-in Beez template for that task.

Another thing that can help is to make a brand new rule, and disable the one you are working on at the moment. This is just in case you altered any of the other settings away from the default settings - some of them are quite sensitive and it's hard to spot where you changed things from the defaults. I'm working on an upgrade that will make this easier to spot.

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1679
Total Polls:
6
Total Posts:
5913
Dormant:
User Info:
 
Total Users:
10789
Newest User:
parus6
Members Online:
1
Guests Online:
296

Online: 
parus6

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked