Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Meta Mod no in Home Page

Meta Mod no in Home Page

hi,
Using Meta Mod since 2009 and I am very well.
Now, however, having changed the layout of my site and I need to Meta Mod not show on the home page.
I tried to use the recipe that I found on the website but does not work.
I should add some other parameter?

primetta
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Meta Mod no in Home Page

Hi primetta,

Hmmm, I wonder if you have re-assigned the front page to a different component? By default the front page of the site (or the menu item that points to it) is a "frontpage" view of the com_content component. On your new site, is it the same?

Perhaps you could turn on advanced debug mode in the MetaMod that is controlling that front page article, and post the results of that when you view your front page?

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Meta Mod no in Home Page

Hello.
for my new website's home page is standard and uses the component com_component Joomla.
The recipe I used is
if (! ($view == "frontpage" && $option == "com_content" ) ) return 58;

My Meta Mod has ID number 58
I used the recipe correctly?
thanks in advance
daniela

primetta
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Meta Mod no in Home Page

MetaMod debug info:
$option: com_content
$view: frontpage
$id:
$Itemid: 161
$timezone: default
$language: it-it
$language_code: it
$language_region: it
Start date/time has been reached.
Including modules:

primetta
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Meta Mod no in Home Page

Hi primetta,

if the MetaMod itself has id of 58 then that would include itself in an endless loop... you need to replace 58 with the ID number of the module that you want to include on the front page. Perhaps that's what you meant.

The debug info that you are showing above shows that you are on the front page. You said that you didn't want the module to be included on the front page, and the debug output shows "Including modules:" which indicates that no module is included. This is doing what you want it to do, I think.

So the question is: does the debug output, and the module you want to include, show up on the other pages of your site?
If you can't see the debug info on the other pages of your site, then perhaps you have put the MetaMod onto only the front page? You probably need it assigned to "ALL" pages.

If you're still having trouble with it, can you post the contents of Debug mode when you are on a different page of the site?

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Re: Meta Mod no in Home Page

Hello Stephen,
many thanks for your help.
Now Meta Mod does not appear on the homepage as I wanted.
Primetta

primetta
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1667
Total Polls:
6
Total Posts:
5910
Total Posts Today:
1
User Info:
 
Total Users:
10144
Newest User:
leonard5412396
Members Online:
2
Guests Online:
151


Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked