Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Erro "Save failed" when i enable rules

Erro "Save failed" when i enable rules

I Stephen,
I use chameleon Pro.
I create a rule for blocking entire site from country but i have this message : "Save failed with the following error: Maximum (20)" redirects followed when i gwant to edit and save an article.
It works when i disable the rule.

Regards

Mande

Technichem
Beginner Modder
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: Erro "Save failed" when i enable rules

Hi Mande,

sorry for the delay in responding to your question.
Could you please describe what your rule actually does at the moment? e.g. is it using GeoIP to detect the country? Then what action is performed when it detects that country? e.g. is it sending people to a particular URL?

I think there might be a couple of things going on:

1 - you may be redirecting people to some sort of landing/error page on your site when they are from a certain country, but on that page Chameleon is again redirecting them back to that same page, making a loop. If this is the case, then you should make a rule in Chameleon that goes FIRST in the list, that detects if people are landing on that page. In the Succeed action, use "quit rule chain" so it allows people to reach that page and doesn't continue on to the next rule that detects their country and redirects them again.

2 - as to why this is happening when you try to save an article: I wonder if you have some condition set up in Chameleon that's catching this page instead of the GeoIP country? Carefully check through all the conditions in the rules you have set up to ensure that hasn't happened. Also try turning on Chameleon's Debug mode (in the Options panel) and watch the debug output to see what conditions are being checked.

Also, if you use 301 redirects then your browser can sometimes cache these. So if you were doing some testing and happened to test a 301 redirect for your own country, then some browsers will aggressively cache that redirect, and won't even send a request to the server if they think that the reply will be a 301 redirect: they will just go directly to the destination page that was cached.

To clear that, clear your browser cache or switch to a new browser and try again.

Hope that helps
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1679
Total Polls:
6
Total Posts:
5933
Posts this week:
4
User Info:
 
Total Users:
4383
Newest User:
kingpen99
Members Online:
0
Guests Online:
184

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked