Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Empty modules still display on site using Helix3 Framework

Empty modules still display on site using Helix3 Framework

I just purchased MetaModPro to prevent empty modules from displaying, but the modules are still displaying even though they're completely empty. I've made sure metamodpro plugin is enabled and it appears first in the plugin list. I've turned off each plugin to see if any conflict with MetaModPro but I get the same results. The site is based on the Helix3 Framework, but when I use MetaMod on a non-Helix site --  it works perfectly. Is there a conflict issue with MetaModPro and Helix3? Or can you point me to any other solutions I can try?

x9494r
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Hi x9494r,

sorry about the delayed reply.

From what you have written, it looks like it might be an incompatibility with the Helix3 framework. Can you point me in the direction of a downloadable template/component using the Helix3 framework, so I can test this out and diagnose what's going on?

Can you please also tell me what Joomla version you are using?

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Hi Stephen, I'm using Joomla version 3.4.1 Stable. You can download a free helix3 template at the link below. Please note I haven't tested all helix3 templates, so I don't know if it was just a coincidence, or if it was due to some other issue. I followed all of the suggestions I could find on this forum, but could only get the modules to collapse on a non-helix site. Thank you in advance for any help you can provide. http://331845739494.10zero6.com/helix3_template_j3.zip

x9494r
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Hi,

I just tested with that template on a basic test site, and the MetaMod Pro plugin correctly removes the empty module positions. So either the problem is with a different Helix template, or it's with a different component on your site.

I did the testing with a completely clean install of the template - no additional configuration at all.

Is it possible for you to send me the actual template you are using if it's different from the one you linked above?

Or, can you identify any other components that are different between the sites where MetaMod Pro worked and the ones where it didn't?

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Below is another template. It’s the one I tested, it just doesn’t have the custom css file that I added (but I did test it without the custom css file and recompiled  the less with the same results). I'm also using Fabrik and JomSocial components but the non-helix site was using those as well. Thank you again for your help.
http://331845739494.10zero6.com/vina_world_ii_v1.2.zip

x9494r
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Hmmm I tried installing the new template but it's giving errors when I try to run it:

Notice: Undefined property: JDocumentHtml::$helix in /Applications/MAMP/htdocs/j362/templates/vina_world_ii/index.php on line 25

I examined the code of the template and I can't see any of the normal "smoking guns" for incompatibility with MetaMod Pro, namely any overriding of the JModuleHelper class. So at this point I don't think it's the template.

Same goes for Fabrik latest version - no overriding of JModuleHelper.

Are you using any other add-ons for Fabrik?

Perhaps I could have a log-in to your site and do some more in-depth investigation? Actually best would be an Akeeba backup file of the site so I can download and run the whole thing locally and examine code more easily incl putting through a PHP debugger.

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

It's also worth checking JomSocial for usage/overriding of JModuleHelper. I don't have a copy of it, so perhaps you could check this yourself: unzip the JomSocial package and any other zip packages that it contains, then grep the contents of the entire package for the string "JModuleHelper". On Mac I use TextMate to do a search over the entire folder, but there are plenty of ways to do it.

What I would be looking for is particularly anything that says "class JModuleHelper". There may be other ways that components can mess up MetaMod Pro, but that's the main one.

Thanks,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Thank you Stephen, I’ll get that backup to you and check for overrides. I’m wondering though since I was able to get the modules to collapse on a non-helix site that was running and identical set of Fabrik and JomSocial components and plugins – wouldn’t that eliminate those two components as a source of conflict? I’m also not getting your error so my other suspicion was that the responsive bootstrap of the template might be interfering with the collapsing? Is that completely crazy?

x9494r
Beginner Modder
ranks
useravatar
Offline
4 Posts
Administrator has disabled public posting

Re: Empty modules still display on site using Helix3 Framework

Hi, yes that would appear to eliminate those 2 components as a source of conflict. But something is doing it! Eventually we'll narrow it down and find the culprit. It will be useful if you can provide that dump.

The bootstrap thing shouldn't be the cause - if MetaMod Pro is doing its job properly, Joomla doesn't even know that a module was published in the given position (where the MetaMod was placed), so should act completely as if there was nothing there, and collapse appropriately.

Cheers
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3314 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1691
Total Polls:
6
Total Posts:
5912
Total Posts Today:
6
User Info:
 
Total Users:
11529
Newest User:
jame380003
Members Online:
1
Guests Online:
180

Online: 
jame380003

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked