Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Metamod is random at interpreting the correct GeoIP location

Metamod is random at interpreting the correct GeoIP location

Hi,
Please assist.
The Metamod module seems to be random at interpreting the correct GeoIP location. The mod will display (or not display) different pages seemingly at random.
Refreshing the Joomla cache seems to change on which pages the mod displayes or not.

1. The latest version of GeoIP.dat is installed.
2. The output from the code attached with "advanced debug" enabled.
3. Have "GeoIP/GeoCity" enabled and set to "GeoIP Country (free or commercial)"
4. Set to "all pages"
5. website: www.datarecovery.co.za
6. Link to video with a demo of the issue: https://www.datarecovery.co.za/downloads/Metamod not displaying on all pages.mp4

Current installation:
MetaMod v3.24, 2015-11-02
MetaMod Pro plugin v3.24, 2015-11-02 is installed and enabled.
Joomla! 3.4.8 Stable [ Ember ] 24-December-2015 19:30 GMT

Output

Array
(
    [PATH] => /sbin:/usr/sbin:/bin:/usr/bin
    [PHPRC] => /home6/ServerPath/public_html/:/usr/php/56/etc/
    [PHP_FCGI_CHILDREN] => 0
    [ORIG_SCRIPT_NAME] => /cgi-sys/fcgid-scripts/fcgiwrapper56
    [ORIG_PATH_TRANSLATED] => /home6/ServerPath/public_html/MyWebSite.co.za/index.php
    [ORIG_PATH_INFO] => /index.php
    [ORIG_SCRIPT_FILENAME] => /usr/local/cpanel/cgi-sys/fcgid-scripts/fcgiwrapper56
    [HTTP_CONNECTION] => close
    [SCRIPT_NAME] => /index.php
    [REQUEST_URI] => /MyWebpage.html
    [QUERY_STRING] =>
    [REQUEST_METHOD] => GET
    [SERVER_PROTOCOL] => HTTP/1.0
    [GATEWAY_INTERFACE] => CGI/1.1
    [REDIRECT_URL] => /index.php
    [REMOTE_PORT] => 42762
    [SCRIPT_FILENAME] => /home6/ServerPath/public_html/MyWebSite.co.za/index.php
    [SERVER_ADMIN] => emailaddress.com
    [DOCUMENT_ROOT] => /home6/ServerPath/public_html/MyWebSite.co.za
    [REMOTE_ADDR] => 174.137.138.84
    [SERVER_PORT] => 443
    [SERVER_ADDR] => 69.89.20.25
    [SERVER_NAME] => www.MyWebSite.co.za
    [SERVER_SOFTWARE] => Apache
    [SERVER_SIGNATURE] =>
Apache Server at www.MyWebSite.co.za Port 443


    [HTTP_COOKIE] => 96379234dbee2501b0fe52164d582931=1s3h68v1np2mqpe1s2j2ok6eg0
    [HTTP_REFERER] => https://www.MyWebSite.co.za/MyWebPages/ … -plan.html
    [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    [HTTP_USER_AGENT] => Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36
    [HTTP_HOST] => www.MyWebSite.co.za
    [SSL_TLS_SNI] => www.MyWebSite.co.za
    [HTTPS] => on
    [MAGICK_THREAD_LIMIT] => 1
    [UNIQUE_ID] => VqiWu0KT9OsAAFbNJi0AAAEL
    [REDIRECT_STATUS] => 200
    [REDIRECT_HANDLER] => fcgidbeta-script
    [REDIRECT_SSL_TLS_SNI] => www.MyWebSite.co.za
    [REDIRECT_HTTPS] => on
    [REDIRECT_MAGICK_THREAD_LIMIT] => 1
    [REDIRECT_HTTP_AUTHORIZATION] =>
    [REDIRECT_UNIQUE_ID] => VqiWu0KT9OsAAFbNJi0AAAEL
    [REDIRECT_REDIRECT_STATUS] => 200
    [REDIRECT_REDIRECT_SSL_TLS_SNI] => www.MyWebSite.co.za
    [REDIRECT_REDIRECT_HTTPS] => on
    [REDIRECT_REDIRECT_MAGICK_THREAD_LIMIT] => 1
    [REDIRECT_REDIRECT_HTTP_AUTHORIZATION] =>
    [REDIRECT_REDIRECT_UNIQUE_ID] => VqiWu0KT9OsAAFbNJi0AAAEL
    [FCGI_ROLE] => RESPONDER
    [PHP_SELF] => /index.php
    [REQUEST_TIME_FLOAT] => 1453889211.5877
    [REQUEST_TIME] => 1453889211
)

Thank you and regards

tec
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Metamod is random at interpreting the correct GeoIP location

Disabling all forms of cache in Joomla seems to solve the problem - Is there a solution to still use Joomla cache and Metamod?

tec
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: Metamod is random at interpreting the correct GeoIP location

Hi tec,

yes, unfortunately the Joomla cache (system cache plugin) is a very blunt instrument. It caches just 1 copy of any given page for its exact URL. When you access that same page from different countries, MetaMod is changing the content of the page, and of course only 1 of those gets cached once the previous cache runs out.

In the past I have modified a version of JotCache to cache a version of each page *per country and URL combination* which solved the particular issue I was having, similar to yours. But even that approach has its downfalls as it massively increases the size of the cache, and required a major rewrite of the cache system. (and that was on Joomla 1.5).

You might be able to get away with turning off the system cache plugin but still using some of the other caching e.g. module caching, but ensure that the MetaMod modules have cache disabled. That would still give you some benefit.

Hope that helps,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3328 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1679
Total Polls:
6
Total Posts:
5933
Posts this week:
4
User Info:
 
Total Users:
4378
Newest User:
miller2341
Members Online:
1
Guests Online:
179

Online: 
dotcommz

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked