Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

Chamelopn only working when debug is on

Chamelopn only working when debug is on

Hello,

I have purchased Chameleon and installed it in two sites.

In both sites I have a template for modern browsers, mobile devices (smartphones) and Internet Explorer 7&8.

I have set rules for modern browsers for smartphones and one single rule for IE7 and one rule for IE8.

When debugging is on, the right template is shown in the according User Agent and the debugging message shows that it works fine.

When swithcing off, the tewmplates wont be shown correctly.

In IE the Template for modern browsers is shown (which looks crap in those old browsers by the way).

Now I have just commented out the and that works.

But that is not a good solution of the problem bec<use I use a form component which enables me to show a message after a visitor has sent me an email.

Any idea what could be the problem? I have looked through the forum but didn't find the solution to my problem.

I don't use a bought template, I use a responsive grid in HTML5 for modern browsers and a rock solid one in XHTML for IE 7&8.

Could it be that the Internet Explorer just is unable to work properly? I have IE 10 installed on my PC under Windows 7 Professional and it crahses all the time when I switch emulator from IE7 ot IE8 etc.

Thanks in advance for your help.

By the way: When going on http://www.metamodpro.com/ nothing happens. Get a fatal error.

Greetings from Berlin (Germany),

Rob van Linda

Edited By: cyberviews
16-Jun-13 14:09:56

cyberviews
Beginner Modder
ranks
useravatar
Offline
2 Posts
User info in posts
Administrator has disabled public posting

Re: Chamelopn only working when debug is on

Hmmm, I have a feeling that the reason why it works with debugging turned on is probably because of caching. There are some caching components (including the system cache plugin) that do not cache the page if there are "messages" in the queue. The debugging code produces these messages. So you need to turn off the system cache plugin.

I know, caching can be vital, so I would suggest that you use JotCache which allows you to set up different caches for different devices, and that should solve that problem.

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3329 Posts
User info in posts
Administrator has disabled public posting

Re: Chamelopn only working when debug is on

Hello Stephen,

my system cache was switched off but I will try JotCache. Never heard of that but I will find out now smile

Andyway, thanks for the quick reply and your help.

Greetz,

Rob

cyberviews
Beginner Modder
ranks
useravatar
Offline
2 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1689
Total Polls:
6
Total Posts:
5941
Posts this week:
1
User Info:
 
Total Users:
5348
Newest User:
towner4218
Members Online:
0
Guests Online:
117

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked