Welcome to the MetaMod and Chameleon Support Forums.

Before posting, please check out the FAQs.

helpme

 

Need extra help with your Joomla site? Consider paid Joomla support by the developer of Chameleon and MetaMod.

 

How do I show modules in the "right" position, only on the homepage?

How do I show modules in the "right" position, only on the homepage?

I want to show some modules in the "right" template position, but only on the homepage.

I've assigned all those modules to the non-existant "right-metamod" position. I have nothing entered in the quicklist field. I've tried:

Code:

if ($core_genius->check("pagetype = frontpage")) return right-metamod; (shows on the homepage, but also on any individual article)

and:

Code:

if ( $view == "frontpage" and $option == "com_content" ) return right-metamod;

But no modules show. If I add right-metamod into the quick include list, everything shows fine on the homepage (a category blog layout), but it also shows on the individual article layouts, which I need to avoid. See the screenshot included to see what I mean, and the domain name. Metamod though is set to only show for "Special" until I get this working right.

Also, when Metamod is published, an empty box shows in it's template position breaking my template layout.

I'm fine with metamod enabling modules on a per-module basis (rather than all in the right column). Whatever works.

I'm using Joomla 2.5.6 and MetaMod 3.10. If there is any other info I can give to help, just ask. smile

Any ideas, anyone?

ProfessorDoom
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: How do I show modules in the "right" position, only on the homepage?

Ok, I've *almost* solved this issue myself. Using the following recipe, I'm able to get metamod to include the modules I want only on the homepage:

Code:

if ($Itemid == 118 and $view == 'category' ) return 'right-metamod';

The only problem is that everywhere else that *doesn't* match this rule, that metamod is still creating a "blank module" rather than just not activating at all like any other unused module in Joomla:

http://xymail.info/owncloud/public.php?service=files&token=2ad98db538340a2a7cf9befa4c36789718ed36af&file=/screenshot.png

Anyone have any ideas how to actually have metamod *not* appear when it isn't called?

ProfessorDoom
Beginner Modder
ranks
useravatar
Offline
2 Posts
Administrator has disabled public posting

Re: How do I show modules in the "right" position, only on the homepage?

Hi Prof,

yes, you definitely need those quotation marks around the names of any module positions that you want to return.

Regarding your other question, please see these FAQs:

http://www.metamodpro.com/metamod/faq/2 … etamod-was
http://www.metamodpro.com/metamod/faq/2 … th-matamod

Cheers,
Stephen

Stephen Brandon
MetaMod / Chameleon developer
If you use MetaMod or Chameleon, please post a rating and a review at the Joomla! Extensions Directory: Chameleon | MetaMod

metamodguy
useravatar
Offline
3313 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1667
Total Polls:
6
Total Posts:
5910
Total Posts Today:
1
User Info:
 
Total Users:
10152
Newest User:
kasautiizindagiikay
Members Online:
0
Guests Online:
220

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked